mlfk.net
当前位置:首页 >> linux下不同发行版编译的软件可以通用吗 >>

linux下不同发行版编译的软件可以通用吗

只要有相应的库,那么就没有问题。不同发行版的库应该还是一样的缺少相应的库就把相应的库安装好就能运行了,这也是为什么安装软件的时候总是要附带的安装几个库。最稳妥的办法就是把用到的不是系统基本库的库打包,里面写个安装脚本探测如果有l...

不同linux发行版之间无非是软件包管理方式有所不同,默认的一些软件和配置不太一样。 软件当然通用(用法,配置文件格式等都通用)

不能吧!软件都是向前兼容的。新的兼容旧的,但旧的一般不兼容新的

bochs 就是图形界面的程序吧?另外,我没听说过 code 模式。 控制台并不是只有 ttyX 的。图形界面里面的 console 一般都是 pty 的。 mplayer 在字符界面下面也可以播放电音的。mplayer 本身只是一个命令行程序

linux上有很多软件都是提供的二进制可执行文件 也就是说已经编译好的文件 所以一般情况下是可以在其它发行版下使用的 不过这得看具体情况 比如软件是64位的而你的发行版却是32位的话就无法执行了 或者cpu架构不同 比如你的软件是arm架构的而你的...

1,不同版本用的 linux 内核一般是不同的版本,大多的发行的最近版本使用的是 linux 新内核。想看看 linux 内核现在到什么版本了可以去 linux.org 看看,kernel.org 有各版本的内核下载。各种发行只是在编译内核里用了不同的配置,你也可以在 ke...

因为不同发行版的linux是不同的,如果想在各种版本安装就直接源码安装,像debian,ubuntu是dpkg包 而fedora和redhat centos 是rpm包 。对于源码的编译方式不一样的

Linux内核是Linux操作系统创始人主持的网站 www.kernel.org 上发布的操作系统的最基本的那些东西。 Linux发行版则是前述那些东西的基础上添加了一些工具软件的基础上构成的一套庞大复杂的操作系统。虽然内核都是一样的,但添加部分各不相同,这...

arm-linux-gcc的4.x版本和3.x版本不兼容。 4.x的应该都没有问题

1,不同版本用的 linux 内核一般是不同的版本,大多的发行的最近版本使用的是 linux 新内核。想看看 linux 内核现在到什么版本了可以去 linux.org 看看,kernel.org 有各版本的内核下载。各种发行只是在编译内核里用了不同的配置,你也可以在 ke...

网站首页 | 网站地图
All rights reserved Powered by www.mlfk.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com